[testing] New text editor


david wrote a month ago:

Long expected and overdue, we're finally making good progress with implementing a new text editor for the site. The goal is that this new editor will soon replace both of the texteditors that we are currently using.

You can test a few basic implementations of the new editor in two ways:

1. On the regular site when editing a webchannel's summary, e.g. here: https://www.tvmaze.com/webchannel/update?id=49 (this is very basic, only supporting bold and italic)

2. On our staging site (https://staging.tvmaze.net/threads/27/test-editor) you can also test the new editor for comments and forum posts. This is a bit more advanced, also supporting strikethrough, links, and quoting.

Please test them out and let me know if you find any issues!

KNOWN ISSUES:

- URL's pasted into the editor are not automatically turned into a link


gazza911 wrote a month ago:

After posting or deleting a comment on an episode, the buttons disappear

Also, this is an annoyance with CKEditor in general; although they support some markdown as input (for example typing in **test** it would become test), it doesn't support the link markdown.

@david In reference to the separators showing, are you setting the buttons to be displayed using the editorConfig's toolbar property?


tnt wrote a month ago:

Yay! Finally :)

So far so good. Tricky formatted text is pasted without problems.

BTW, URL's are converted correctly for me. However, this issue seems to be present in the current editor (for some time).


Thomas wrote a month ago:

gazza911 wrote:
After posting or deleting a comment on an episode, the buttons disappear

The bold and italic buttons Gazza is referring to. Actual comment button is yet present.

and wouldn't it be better to have those buttons appear too when you edit your original text posted?


gazza911 wrote a month ago:

Thomas wrote:
The bold and italic buttons Gazza is referring to. Actual comment button is yet present.

and wouldn't it be better to have those buttons appear too when you edit your original text posted?

They will show when editing a comment if you refresh the page first


tnt wrote a month ago:

gazza911 wrote:
They will show when editing a comment if you refresh the page first

If you start editing without refresh you'll be editing HTML source of the comment :)

Also the editor buttons are disappearing if you delete the comment, and the editor will stay in the HTML mode until you manually refresh the page.


david wrote a month ago:

The issues you mentioned should all be fixed (on staging).


gazza911 wrote a month ago:

david wrote:
The issues you mentioned should all be fixed (on staging).

Seems to be working fine for me now :)


david wrote 23 days ago:

The new editor is now live for forum posts & comments. If anyone has issues, let me know!


gazza911 wrote 23 days ago:

david wrote:
The new editor is now live for forum posts & comments. If anyone has issues, let me know!

Looks like networks are still using the old editor


david wrote 23 days ago:

gazza911 wrote:
Looks like networks are still using the old editor

Yep, just forums and comments were switched.


gazza911 wrote 23 days ago:

david wrote:
Yep, just forums and comments were switched.

Web Channels appear to have been switched, was that intentional?

(I know it was in staging, just wanted to check if you meant it go live for there)


Jan wrote 23 days ago:

gazza911 wrote:
Web Channels appear to have been switched, was that intentional?

Yes.


david wrote 23 days ago:

That part has been live all along ;)


david wrote 21 days ago:

tnt wrote:
Small bug: when pasting URL link into text, everything you type after is added to this link, until you press Enter (CR)

https://www.youtube.com/watch?v=66s-9cm5Dgo this text impossible to separate

Chrome 73.0.3683.103, macOS 10.13.6

I guess it's kind of ambiguous which kind of behavior is ideal here, not sure if they'll consider this to be a bug. Either way what you can do is press the right arrow key, and you'll "escape" from the link and are able to type regular text again.


tnt wrote 21 days ago:

david wrote:
I guess it's kind of ambiguous which kind of behavior is ideal here, not sure if they'll consider this to be a bug. Either way what you can do is press the right arrow key, and you'll "escape" from the link and are able to type regular text again.

Heh, it's actually working :) Thanks, I can live with it :)

Previously the space bar had the same effect, but arrow will do as well.


gazza911 wrote 21 days ago:

If you type **text** if will display as text and then anything you type after that is formatted normally (as you've ended the bold markdown)

If you type ***text*** / _**text**_ then it will display as text, however whatever you type afterwards will still be in bold

Similarly __*text*__ = text but whatever you type afterwards will still be in italics

P.S This only happens on typing, not pasting (however if you type a second underscore or asterisk in a line it will apply the formatting)


tnt wrote 21 days ago:

It's curious why not every URL is converted to link? For example, if I copy an URL from the browser's address field, it is converted https://www.tvmaze.com/shows/82/game-of-thrones/episodes
However, if I do the same via the right click menu - copy link address, it is pasted as text https://www.tvmaze.com/shows/82/game-of-thrones/episodes

I think the old editor was behaving the same way.


gazza911 wrote 21 days ago:

tnt wrote:
However, if I do the same via the right click menu - copy link address, it is pasted as text

That's just how the browser works when you copy link address; you're copying just the address (which is just a string), not the link itself. In order for it to do that, you would have to on paste determine if it matches a regular expression of a link.

Anything which is copied as a link will get marked as one; if I copy chrome://settings from the address bar, it will be put as a link.